using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<[^>]*>.*?</[^>]*>(*SKIP)(*FAIL))|\btest\b";
string substitution = @"<span style=""color: #FF0000;"">\0</span>";
string input = @"This is a great test! We're testing something awesome. Click here to <a href=""whatever"">test it!</a>.";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}