import re
regex = re.compile(r"(?:<[^>]*>.*?</[^>]*>(*SKIP)(*FAIL))|\btest\b", flags=re.DOTALL)
test_str = "This is a great test! We're testing something awesome. Click here to <a href=\"whatever\">test it!</a>."
subst = "<span style=\"color: #FF0000;\">\\0</span>"
result = regex.sub(subst, test_str)
if result:
print(result)