re = /(?:<[^>]*>.*?<\/[^>]*>(*SKIP)(*FAIL))|\btest\b/
str = 'This is a great test! We\'re testing something awesome. Click here to <a href="whatever">test it!</a>.'
subst = '<span style="color: #FF0000;">\\0</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result