import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<[^>]*>.*?</[^>]*>(*SKIP)(*FAIL))|\\btest\\b";
final String string = "This is a great test! We're testing something awesome. Click here to <a href=\"whatever\">test it!</a>.";
final String subst = "<span style=\"color: #FF0000;\">\\0</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}