$re = '~(?:<[^>]*>.*?</[^>]*>(*SKIP)(*FAIL))|\btest\b~s';
$str = 'This is a great test! We\'re testing something awesome. Click here to <a href="whatever">test it!</a>.';
$subst = "<span style=\"color: #FF0000;\">\0</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;