import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]{2}(\\.|\\s)?[0-9]{3}(\\.|\\s)?[0-9]{2}\\n";
final String string = "80020509\n"
+ "80.020-050\n"
+ "80-250.404\n"
+ "80.405.405\n"
+ "80405.405";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}