use strict;
my $str = '80020509
80.020-050
80-250.404
80.405.405
80405.405';
my $regex = qr/[0-9]{2}(\.|\s)?[0-9]{3}(\.|\s)?[0-9]{2}\n/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}