const regex = /[0-9]{2}(\.|\s)?[0-9]{3}(\.|\s)?[0-9]{2}\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]{2}(\\.|\\s)?[0-9]{3}(\\.|\\s)?[0-9]{2}\\n', 'gm')
const str = `80020509
80.020-050
80-250.404
80.405.405
80405.405`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}