#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-z\.]+@ha-target.com"
Local $sString = "0 00-1.997 1.884z"" & @CRLF & _
" ></path>" & @CRLF & _
" <path" & @CRLF & _
" d="M18 8.118l-8 4-8-4V14a2 2 0 002 2h12a2 2 0 002-2V8.118z"" & @CRLF & _
" ></path>" & @CRLF & _
" </svg>" & @CRLF & _
" melissa.wright@ha-target.com" & @CRLF & _
" </p>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="px-4 py-4">" & @CRLF & _
" <div class="flex items-center text-grey-darker mb-4">" & @CRLF & _
" <svg" & @CRLF & _
" class="h-6 w-6 tex"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")