import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-z\\.]+@ha-target.com";
final String string = "0 00-1.997 1.884z\"\n"
+ " ></path>\n"
+ " <path\n"
+ " d=\"M18 8.118l-8 4-8-4V14a2 2 0 002 2h12a2 2 0 002-2V8.118z\"\n"
+ " ></path>\n"
+ " </svg>\n"
+ " melissa.wright@ha-target.com\n"
+ " </p>\n"
+ " </div>\n"
+ " </div>\n"
+ " <div class=\"px-4 py-4\">\n"
+ " <div class=\"flex items-center text-grey-darker mb-4\">\n"
+ " <svg\n"
+ " class=\"h-6 w-6 tex";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}