// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[a-z\.]+@ha-target.com").unwrap();
let string = "0 00-1.997 1.884z\"
></path>
<path
d=\"M18 8.118l-8 4-8-4V14a2 2 0 002 2h12a2 2 0 002-2V8.118z\"
></path>
</svg>
melissa.wright@ha-target.com
</p>
</div>
</div>
<div class=\"px-4 py-4\">
<div class=\"flex items-center text-grey-darker mb-4\">
<svg
class=\"h-6 w-6 tex";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}