# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[a-z\.]+@ha-target.com"
test_str = ("0 00-1.997 1.884z\"\n"
" ></path>\n"
" <path\n"
" d=\"M18 8.118l-8 4-8-4V14a2 2 0 002 2h12a2 2 0 002-2V8.118z\"\n"
" ></path>\n"
" </svg>\n"
" melissa.wright@ha-target.com\n"
" </p>\n"
" </div>\n"
" </div>\n"
" <div class=\"px-4 py-4\">\n"
" <div class=\"flex items-center text-grey-darker mb-4\">\n"
" <svg\n"
" class=\"h-6 w-6 tex")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.