import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(подрост:\\s+)(?<composition>[0-9А-Я]+)?\\s?(?<age>\\(\\d+\\))?\\s?(?<height>\\d+,\\d\\sм)?\\s?,?\\s?(\\d+,\\d\\s+тыс.шт\\/га),?([А-Яа-я]+)?";
final String string = "подрост: 10Е (20) 3,0 м, 1,5 тыс.шт/га\n"
+ "подрост: 10Е 3,0 м, 1,5 тыс.шт/га\n"
+ "подрост: 10Е 1,5 тыс.шт/га\n"
+ "подрост: 6ЯС3И1ОР (15) 2,0 м, 3,0 тыс.шт/га,благонадежный";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}