const regex = /(подрост:\s+)(?<composition>[0-9А-Я]+)?\s?(?<age>\(\d+\))?\s?(?<height>\d+,\d\sм)?\s?,?\s?(\d+,\d\s+тыс.шт\/га),?([А-Яа-я]+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(подрост:\\s+)(?<composition>[0-9А-Я]+)?\\s?(?<age>\\(\\d+\\))?\\s?(?<height>\\d+,\\d\\sм)?\\s?,?\\s?(\\d+,\\d\\s+тыс.шт\\\/га),?([А-Яа-я]+)?', 'gm')
const str = `подрост: 10Е (20) 3,0 м, 1,5 тыс.шт/га
подрост: 10Е 3,0 м, 1,5 тыс.шт/га
подрост: 10Е 1,5 тыс.шт/га
подрост: 6ЯС3И1ОР (15) 2,0 м, 3,0 тыс.шт/га,благонадежный`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}