import re
regex = re.compile(r"(подрост:\s+)(?<composition>[0-9А-Я]+)?\s?(?<age>\(\d+\))?\s?(?<height>\d+,\d\sм)?\s?,?\s?(\d+,\d\s+тыс.шт\/га),?([А-Яа-я]+)?", flags=re.MULTILINE)
test_str = ("подрост: 10Е (20) 3,0 м, 1,5 тыс.шт/га\n"
"подрост: 10Е 3,0 м, 1,5 тыс.шт/га\n"
"подрост: 10Е 1,5 тыс.шт/га\n"
"подрост: 6ЯС3И1ОР (15) 2,0 м, 3,0 тыс.шт/га,благонадежный")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")