use strict;
my $str = 'подрост: 10Е (20) 3,0 м, 1,5 тыс.шт/га
подрост: 10Е 3,0 м, 1,5 тыс.шт/га
подрост: 10Е 1,5 тыс.шт/га
подрост: 6ЯС3И1ОР (15) 2,0 м, 3,0 тыс.шт/га,благонадежный';
my $regex = qr/(подрост:\s+)(?<composition>[0-9А-Я]+)?\s?(?<age>\(\d+\))?\s?(?<height>\d+,\d\sм)?\s?,?\s?(\d+,\d\s+тыс.шт\/га),?([А-Яа-я]+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}