#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=(\s\w{3}\s\d{2}\s|))-\s\d+$|\d+\s-$|\d+$"
Local $sString = "Revenue as of Mar 19 12200" & @CRLF & _
"" & @CRLF & _
"Revenue as of end of quarter 12200" & @CRLF & _
"" & @CRLF & _
"Revenue as of Mar 19 12200 -" & @CRLF & _
"" & @CRLF & _
"Revenue as of Mar 19 - 12200"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")