re = /(?<=(\s\w{3}\s\d{2}\s|))-\s\d+$|\d+\s-$|\d+$/m
str = 'Revenue as of Mar 19 12200
Revenue as of end of quarter 12200
Revenue as of Mar 19 12200 -
Revenue as of Mar 19 - 12200'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end