$re = '/(?<=(\s\w{3}\s\d{2}\s|))-\s\d+$|\d+\s-$|\d+$/m';
$str = 'Revenue as of Mar 19 12200
Revenue as of end of quarter 12200
Revenue as of Mar 19 12200 -
Revenue as of Mar 19 - 12200';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);