import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(\\s\\w{3}\\s\\d{2}\\s|))-\\s\\d+$|\\d+\\s-$|\\d+$";
final String string = "Revenue as of Mar 19 12200\n\n"
+ "Revenue as of end of quarter 12200\n\n"
+ "Revenue as of Mar 19 12200 -\n\n"
+ "Revenue as of Mar 19 - 12200";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}