import re
regex = re.compile(r"(?<=(\s\w{3}\s\d{2}\s|))-\s\d+$|\d+\s-$|\d+$", flags=re.MULTILINE)
test_str = ("Revenue as of Mar 19 12200\n\n"
"Revenue as of end of quarter 12200\n\n"
"Revenue as of Mar 19 12200 -\n\n"
"Revenue as of Mar 19 - 12200")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")