#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\/)[a-z0-9-]+?$"
Local $sString = "/magasins/vos-magasins/le-bhv-marais" & @CRLF & _
"/magasins/vos-magasins/le-bhv-marais-homme" & @CRLF & _
"/magasins/vos-magasins/bhv-marais-parly2" & @CRLF & _
"/magasins/le-bhv-marais-la-niche" & @CRLF & _
"/magasins/vos-magasins/mobicity-au-bhv-marais" & @CRLF & _
"/magasins/vos-magasins/gucci-au-bhv-marais"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")