re = /(?<=\/)[a-z0-9-]+?$/m
str = '/magasins/vos-magasins/le-bhv-marais
/magasins/vos-magasins/le-bhv-marais-homme
/magasins/vos-magasins/bhv-marais-parly2
/magasins/le-bhv-marais-la-niche
/magasins/vos-magasins/mobicity-au-bhv-marais
/magasins/vos-magasins/gucci-au-bhv-marais'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end