$re = '/(?<=\/)[a-z0-9-]+?$/m';
$str = '/magasins/vos-magasins/le-bhv-marais
/magasins/vos-magasins/le-bhv-marais-homme
/magasins/vos-magasins/bhv-marais-parly2
/magasins/le-bhv-marais-la-niche
/magasins/vos-magasins/mobicity-au-bhv-marais
/magasins/vos-magasins/gucci-au-bhv-marais';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);