# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.\:.[0-9]*//;t' <<< "hostname.domain.com : 83929849392"