use strict;
my $str = 'hostname.domain.com : 83929849392';
my $regex = qr/.\:.[0-9]*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";