#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".\:.[0-9]*"
Local $sString = "hostname.domain.com : 83929849392"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)