$re = '/.\:.[0-9]*/';
$str = 'hostname.domain.com : 83929849392';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;