const regex = /.\:.[0-9]*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.\\:.[0-9]*', '')
const str = `hostname.domain.com : 83929849392`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);