# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/get(\w+)/\l$1/gm;t' <<< "getThis, getThat, getSomethingElse"