using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!(\d)\1{8})\d{9}";
string input = @"111111111 // false
222222222 // false
333333333 // false
077546997 // true
123566566 // true";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}