$re = '/(?!(\d)\1{8})\d{9}/';
$str = '111111111 // false
222222222 // false
333333333 // false
077546997 // true
123566566 // true';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);