const regex = /(?!(\d)\1{8})\d{9}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!(\\d)\\1{8})\\d{9}', 'g')
const str = `111111111 // false
222222222 // false
333333333 // false
077546997 // true
123566566 // true`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}