re = /(?!(\d)\1{8})\d{9}/
str = '111111111 // false
222222222 // false
333333333 // false
077546997 // true
123566566 // true'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end