import re
regex = re.compile(r"(?!(\d)\1{8})\d{9}")
test_str = ("111111111 // false\n"
"222222222 // false\n"
"333333333 // false\n"
"077546997 // true\n"
"123566566 // true")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")