#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m) - 0*(\d+)(?!.* - ).*\.(?:jpe?g|png|tiff?)$"
Local $sString = "2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 01 [Declaration 1].png" & @CRLF & _
"2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 02 [Declaration 2].png" & @CRLF & _
"2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 07 [Fire].png" & @CRLF & _
"2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 12 [Fungi etc].png" & @CRLF & _
"" & @CRLF & _
" - 012test.png" & @CRLF & _
"" & @CRLF & _
" - 12 - 12testhere.png" & @CRLF & _
"" & @CRLF & _
" - 012 - test.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")