using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" - 0*(\d+)(?!.* - ).*\.(?:jpe?g|png|tiff?)$";
string input = @"2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 01 [Declaration 1].png
2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 02 [Declaration 2].png
2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 07 [Fire].png
2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 12 [Fungi etc].png
- 012test.png
- 12 - 12testhere.png
- 012 - test.png";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}