$re = '/ - 0*(\d+)(?!.* - ).*\.(?:jpe?g|png|tiff?)$/m';
$str = '2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 01 [Declaration 1].png
2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 02 [Declaration 2].png
2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 07 [Fire].png
2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 12 [Fungi etc].png
- 012test.png
- 12 - 12testhere.png
- 012 - test.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);