import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " - 0*(\\d+)(?!.* - ).*\\.(?:jpe?g|png|tiff?)$";
final String string = "2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 01 [Declaration 1].png\n"
+ "2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 02 [Declaration 2].png\n"
+ "2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 07 [Fire].png\n"
+ "2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 12 [Fungi etc].png\n\n"
+ " - 012test.png\n\n"
+ " - 12 - 12testhere.png\n\n"
+ " - 012 - test.png";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}