# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r" - 0*(\d+)(?!.* - ).*\.(?:jpe?g|png|tiff?)$"
test_str = ("2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 01 [Declaration 1].png\n"
"2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 02 [Declaration 2].png\n"
"2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 07 [Fire].png\n"
"2020-07-24 07;17;09 - ABCD - 12345-67890 (14 Main St) - 12 [Fungi etc].png\n\n"
" - 012test.png\n\n"
" - 12 - 12testhere.png\n\n"
" - 012 - test.png")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.