#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([0-9]+\.?\d*e.\d+)|([0-9]+\.?\d*)|(\.\d+)"
Local $sString = "0.1111000-.0002+.0001+.-.0000002-999-.325/.3000-0.000-3.+4908./0./.01+./.-.+456+0.4-" & @CRLF & _
"1.1111111118888889e+21345" & @CRLF & _
"1.11113333333333e-734" & @CRLF & _
"0.11113333333333e-7444" & @CRLF & _
"0.11113333333333e-755"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")