import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]+\\.?\\d*e.\\d+)|([0-9]+\\.?\\d*)|(\\.\\d+)";
final String string = "0.1111000-.0002+.0001+.-.0000002-999-.325/.3000-0.000-3.+4908./0./.01+./.-.+456+0.4-\n"
+ "1.1111111118888889e+21345\n"
+ "1.11113333333333e-734\n"
+ "0.11113333333333e-7444\n"
+ "0.11113333333333e-755";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}