package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]+\.?\d*e.\d+)|([0-9]+\.?\d*)|(\.\d+)`)
var str = `0.1111000-.0002+.0001+.-.0000002-999-.325/.3000-0.000-3.+4908./0./.01+./.-.+456+0.4-
1.1111111118888889e+21345
1.11113333333333e-734
0.11113333333333e-7444
0.11113333333333e-755`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}