# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9]+\.?\d*e.\d+)|([0-9]+\.?\d*)|(\.\d+)"
test_str = ("0.1111000-.0002+.0001+.-.0000002-999-.325/.3000-0.000-3.+4908./0./.01+./.-.+456+0.4-\n"
"1.1111111118888889e+21345\n"
"1.11113333333333e-734\n"
"0.11113333333333e-7444\n"
"0.11113333333333e-755")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.