const regex = /([0-9]+\.?\d*e.\d+)|([0-9]+\.?\d*)|(\.\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]+\\.?\\d*e.\\d+)|([0-9]+\\.?\\d*)|(\\.\\d+)', 'gm')
const str = `0.1111000-.0002+.0001+.-.0000002-999-.325/.3000-0.000-3.+4908./0./.01+./.-.+456+0.4-
1.1111111118888889e+21345
1.11113333333333e-734
0.11113333333333e-7444
0.11113333333333e-755`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}