#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\[((?!attr4)[^\]])*\])"
Local $sString = "root/element1/element2[@attr1='abc']/element3[attr3='xyz']/element4/element5[attr4='pqr']/element6/element7" & @CRLF & _
"" & @CRLF & _
"root/element1/element2[@attr5='81273']/element3[param5='544^@#$*!#']/element4/element5[attr4='pqr']/element6/element7" & @CRLF & _
"" & @CRLF & _
"root/element1/element2/element3/element4/element5[attr4='pqr']/element6/element7" & @CRLF & _
"root/element1/element2/element3/element4/element5[attr4='pqr']/element6/element7"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")