using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[((?!attr4)[^\]])*\])";
string input = @"root/element1/element2[@attr1='abc']/element3[attr3='xyz']/element4/element5[attr4='pqr']/element6/element7
root/element1/element2[@attr5='81273']/element3[param5='544^@#$*!#']/element4/element5[attr4='pqr']/element6/element7
root/element1/element2/element3/element4/element5[attr4='pqr']/element6/element7
root/element1/element2/element3/element4/element5[attr4='pqr']/element6/element7";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}