use strict;
my $str = 'root/element1/element2[@attr1=\'abc\']/element3[attr3=\'xyz\']/element4/element5[attr4=\'pqr\']/element6/element7
root/element1/element2[@attr5=\'81273\']/element3[param5=\'544^@#$*!#\']/element4/element5[attr4=\'pqr\']/element6/element7
root/element1/element2/element3/element4/element5[attr4=\'pqr\']/element6/element7
root/element1/element2/element3/element4/element5[attr4=\'pqr\']/element6/element7';
my $regex = qr/(\[((?!attr4)[^\]])*\])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}