$re = '/(\[((?!attr4)[^\]])*\])/';
$str = 'root/element1/element2[@attr1=\'abc\']/element3[attr3=\'xyz\']/element4/element5[attr4=\'pqr\']/element6/element7
root/element1/element2[@attr5=\'81273\']/element3[param5=\'544^@#$*!#\']/element4/element5[attr4=\'pqr\']/element6/element7
root/element1/element2/element3/element4/element5[attr4=\'pqr\']/element6/element7
root/element1/element2/element3/element4/element5[attr4=\'pqr\']/element6/element7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);