const regex = /(\[((?!attr4)[^\]])*\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[((?!attr4)[^\\]])*\\])', 'g')
const str = `root/element1/element2[@attr1='abc']/element3[attr3='xyz']/element4/element5[attr4='pqr']/element6/element7
root/element1/element2[@attr5='81273']/element3[param5='544^@#\$*!#']/element4/element5[attr4='pqr']/element6/element7
root/element1/element2/element3/element4/element5[attr4='pqr']/element6/element7
root/element1/element2/element3/element4/element5[attr4='pqr']/element6/element7`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}